Repository navigation
build: Upgrade certifi, pip, and pip-tools [ulmo] - #69
Merged
Merged
Conversation
Upgrades certifi from 2024.8.30 to 2026.10.19, pip from 24.2 to 26.2.2, and pip-tools from 7.4.1 to 7.6.2. pip-tools is upgraded because older versions don't work with pip 26.2+. certifi older than 2026.10.19 and pip older than 26.2.2 trust the compromised emSign intermediate CAs. Generated with `make upgrade` limited to --upgrade-package for those packages. Part of: openedx/public-engineering#574 Co-authored-by: Claude Opus 5.5 <noreply@anthropic.com>
UsamaSadiq
approved these changes
Oct 26, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Upgrades certifi from 2024.8.30 to 2026.10.19, pip from 24.2 to 26.2.2,
and pip-tools from 7.4.1 to 7.6.2. pip-tools is upgraded because older
versions don't work with pip 26.2+. certifi older than 2026.10.19 and
pip older than 26.2.2 trust the compromised emSign intermediate CAs.
Generated with
make upgradelimited to --upgrade-package for thosepackages.
The recompile also adds jeepney 0.9.0, secretstorage 3.5.0 and cryptography 46.0.0 to
requirements/doc.txtonly. twine pulls in keyring, which needs them on Linux, and they were missing because the branch was last compiled on macOS. cryptography 46.0.0 has known advisories, but it is the newest version compatible with the existingcffi==1.17.1pin, so a Linux install ofdoc.txtalready gets 46.0.0 today. This just makes that pin explicit.Part of: openedx/public-engineering#574
🤖 Generated with Claude Code